Module Renaming: GHC.Core.Op
sylvain at haskus.fr
Fri Apr 3 21:29:38 UTC 2020
"Op" stands for "Operation" but it's not very obvious (ironically when I
started this renaming work one of the motivation was to avoid ambiguous
The idea was to separate Core types from Core
transformations/analyses/passes. I couldn't find something better then
"Operation" to sum up the latter category but I concede it's not very good.
But perhaps we should do the opposite as we're doing in GHC.Tc: put all
the Core types in GHC.Core.Types and move everything operation from
GHC.Core.Op to GHC.Core?
On 03/04/2020 22:26, Andreas Klebinger wrote:
> Hello devs,
> While I looked at the renaming a bit when proposed I only just realized
> we seem to be using Op as a short name for optimize.
> I find this very unintuitive. Can we spare another letter to make this
> GHC.Core.Opt instead?
> We use opt pretty much everywhere else in GHC already.
> ghc-devs mailing list
> ghc-devs at haskell.org
More information about the ghc-devs