[xmonad] GenerateManpage.hs doesn't work on Maverick

adam vogt vogt.adam at gmail.com
Wed Mar 9 19:28:34 CET 2011

On Wed, Mar 9, 2011 at 2:48 AM, Karl Ljungkvist <k.ljungkvist at gmail.com> wrote:
> Hi,
> I'm trying to make a developement package of xmonad for ubuntu. When I run
> runhaskell GenerateManpage.hs
> under Ubuntu 10.10 (Maverick Meerkat), I get the following error:
> GenerateManpage.hs: user error (Pattern match failure in do expression
> at util/GenerateManpage.hs:79:4-17)
> The following package versions are installed:
> libghc6-pandoc-dev             
> libghc6-regex-base-dev                   0.93.1-8
> libghc6-regex-posix-dev                  0.94.1-2
> I've tried running it under Ubuntu 10.04, and there it works. There,
> these version are installed:
> libghc6-regex-base-dev                   0.93.1-6
> libghc6-regex-posix-dev                  0.93.2-5
> libghc6-pandoc-dev             
> It also works under up-to-date Arch Linux with these versions:
> haskell-pandoc  
> haskell-regex-base        0.93.2-1.1
> haskell-regex-posix       0.94.2-1
> I can't really see what in GenerateManpage.hs is so sensitive to these
> versions. It might of course be related to something completely
> different. Can someone help me out here?


Pandoc has changed enough to break GenerateManpage.hs since we first
used it for the manpage. But I think your issue is that ubuntu does
not seem to include the templates listed in [1] if we can believe [2].
Maybe there is another package you must install. You could use your
own template if you modify the GenerateManpage to put something like:

template <- readFile "path/to/your/own/template.man"

where we currently have:

Right template <- getDefaultTemplate Nothing "man"

and the same for the html template.

[1] http://hackage.haskell.org/packages/archive/pandoc/
[2] http://packages.ubuntu.com/lucid/i386/libghc6-pandoc-dev/filelist

-- Adam

More information about the xmonad mailing list