[xmonad] GenerateManpage.hs doesn't work on Maverick

Karl Ljungkvist k.ljungkvist at gmail.com
Wed Mar 9 08:48:36 CET 2011


I'm trying to make a developement package of xmonad for ubuntu. When I run

runhaskell GenerateManpage.hs

under Ubuntu 10.10 (Maverick Meerkat), I get the following error:

GenerateManpage.hs: user error (Pattern match failure in do expression
at util/GenerateManpage.hs:79:4-17)

The following package versions are installed:
libghc6-regex-base-dev                   0.93.1-8
libghc6-regex-posix-dev                  0.94.1-2

I've tried running it under Ubuntu 10.04, and there it works. There,
these version are installed:
libghc6-regex-base-dev                   0.93.1-6
libghc6-regex-posix-dev                  0.93.2-5

It also works under up-to-date Arch Linux with these versions:
haskell-regex-base        0.93.2-1.1
haskell-regex-posix       0.94.2-1

I can't really see what in GenerateManpage.hs is so sensitive to these
versions. It might of course be related to something completely
different. Can someone help me out here?


Karl Ljungkvist

More information about the xmonad mailing list