[xmonad] darcs patch: Correct warnings with ghc-6.12 (and 1 more)
vogt.adam at gmail.com
Mon Jan 18 12:00:12 EST 2010
* On Monday, January 18 2010, Daniel Schoepe wrote:
>Excerpts from Adam Vogt's message of Mon Jan 18 17:26:14 +0100 2010:
>> Mon Jan 18 11:22:56 EST 2010 Adam Vogt <vogt.adam at gmail.com>
>> * Rename numlockMask to numberlockMask to help users of the template config.
>Since configs will be broken with regard to numlockMask anyway, wouldn't it be
>more prudent to rename it to filterModifiersMask or something along
>that line, since users of e.g. Ukranian keyboard layouts had to add more
>modifier bits to numlockMask to get various things like Prompt to work
>properly. So something like filterModifiersMask would resemble its
>usage more closely.
The field moving from XConfig to XState is still supposed to contain a
numlockMask... or at least it does once (setNumlockMask :: X ()) is run
when xmonad starts up.
Users could still modify that field once xmonad is running.
However, the actual name of the field doesn't matter to me, so long as
it isn't numlockMask (since that leads to very confusing error messages
by ghc for users who will try an old template config).... so send an
amended patch if this is important to you?
More information about the xmonad