[xmonad] darcs patch: Correct warnings with ghc-6.12 (and 1 more)
daniel.schoepe at googlemail.com
Mon Jan 18 11:34:43 EST 2010
Excerpts from Adam Vogt's message of Mon Jan 18 17:26:14 +0100 2010:
> Mon Jan 18 11:22:56 EST 2010 Adam Vogt <vogt.adam at gmail.com>
> * Rename numlockMask to numberlockMask to help users of the template config.
Since configs will be broken with regard to numlockMask anyway, wouldn't it be
more prudent to rename it to filterModifiersMask or something along
that line, since users of e.g. Ukranian keyboard layouts had to add more
modifier bits to numlockMask to get various things like Prompt to work
properly. So something like filterModifiersMask would resemble its
usage more closely.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 836 bytes
Desc: not available
Url : http://www.haskell.org/pipermail/xmonad/attachments/20100118/981297a1/signature.bin
More information about the xmonad