[xmonad] darcs patch: Correct warnings with ghc-6.12 (and 1 more)

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Mon Jan 18 12:49:38 EST 2010

Adam Vogt <vogt.adam at gmail.com> writes:
>     - compatibility with base-4 or 3 (base-2 untested) by using
>       extensible-exceptions. This adds an additional dependency for users of
>       ghc<6.10)

>From memory, extensible-exceptions needs >=GHC-6.8, so using it means
there's no more base-2 compatability.  On the other hand, do we really
need to keep support for <GHC-6.8 ?

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the xmonad mailing list