[xmonad] Problems getting decoration to work with default tiled layout

Brent Yorgey byorgey at seas.upenn.edu
Tue Jun 16 14:15:59 EDT 2009

On Tue, Jun 16, 2009 at 03:51:43PM +0200, Toby Cubitt wrote:
> Brent Yorgey wrote:
> > On Tue, Jun 16, 2009 at 03:02:52PM +0200, Toby Cubitt wrote:
> >>
> >> *****
> >> import XMonad
> >> import XMonad.Layout.SimpleDecoration
> >>
> >> myLayoutHook = simpleDeco shrinkText defaultTheme
> >>                  (layoutHook defaultConfig)
> >>
> >> main = xmonad $ defaultConfig {
> >>          layoutHook = myLayoutHook
> >>        }
> >> *****
> >>
> > are you sure you didn't accidentally switch to
> > fullscreen mode (i.e. with mod-space)?
> To be sure, I tried hitting mod-space a few times, and also tried
> replacing the above layout hook with:
> myLayoutHook = simpleDeco shrinkText defaultTheme
>                  (Tall 1 (1/300) (1/2))
> with no change in the behaviour.
> > You should also try hitting
> > mod-shift-space to to a hard reload of the layout, sometimes that's
> > necessary when changing your layout (since xmonad tries very hard to
> > keep your layout state across restarts).
> Also doesn't seem to help. I also tried quitting xmonad completely (M-S-q)
> and logging into X again, but still see the same behaviour.

Yeah, quitting completely and restarting should do it if mod-shift-space does.

Hmm. So, having gotten the simple stuff out of the way, I tried this
config myself (in fact, I am using it right now while composing this
email) and it works fine for me.  I get tiled windows with little
title boxes above each one.  So for now I am going with the hypothesis
that your config is not successfully being compiled, and xmonad is
using a previous config in its place.  (Although there are definitely
no syntax errors in the config you pasted; I copied and pasted it and
it works fine.)  A few more things to check:

  1. Do you have the 'xmessage' utility installed?  One possibility is
     that xmonad is generating errors but is not able to show them to you
     if you don't have 'xmessage'.

  2. Also check ~/.xsession-errors and ~/.xmonad/xmonad.errors for any
     error messages.

  3. You can also try loading your xmonad.hs in ghci to see whether
     there are any errors: cd into ~/.xmonad and type 'ghci'; then at
     the ghci prompt type ':load xmonad.hs'.

If nothing likely comes out of any of these, then we'll have to go
back to the drawing board.


More information about the xmonad mailing list