[xmonad] Problems getting decoration to work with default tiled layout

Toby Cubitt tsc25 at cantab.net
Tue Jun 16 13:59:38 EDT 2009

Brent Yorgey wrote:
> On Tue, Jun 16, 2009 at 03:51:43PM +0200, Toby Cubitt wrote:
>> Brent Yorgey wrote:
>>> On Tue, Jun 16, 2009 at 03:02:52PM +0200, Toby Cubitt wrote:
>>>> *****
>>>> import XMonad
>>>> import XMonad.Layout.SimpleDecoration
>>>> myLayoutHook = simpleDeco shrinkText defaultTheme
>>>>                  (layoutHook defaultConfig)
>>>> main = xmonad $ defaultConfig {
>>>>          layoutHook = myLayoutHook
>>>>        }
>>>> *****
> Hmm. So, having gotten the simple stuff out of the way, I tried this
> config myself (in fact, I am using it right now while composing this
> email) and it works fine for me.  I get tiled windows with little
> title boxes above each one.  So for now I am going with the hypothesis
> that your config is not successfully being compiled, and xmonad is
> using a previous config in its place.  (Although there are definitely
> no syntax errors in the config you pasted; I copied and pasted it and
> it works fine.)  A few more things to check:
>   1. Do you have the 'xmessage' utility installed?  One possibility is
>      that xmonad is generating errors but is not able to show them to you
>      if you don't have 'xmessage'.

xmessage is definitely installed. I tried introducing deliberate syntax
errors in xmonad.hs, and mod-q then pops up a message. I also tested
"xmessage test" from an xterm.

>   2. Also check ~/.xsession-errors and ~/.xmonad/xmonad.errors for any
>      error messages.

~/xmonad.errors is empty. ~/.xsession-errors contains the following:

Warning: Cannot convert string "nil2" to type FontStruct
xterm: cannot load font
user error (createFontSet)
No running windows found
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
Waiting for Emacs...user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)
user error (createFontSet)

This is after a fresh log-in to xmonad, with the following ~/.xsession:

***** ~/.xsession *****
export PATH="~/bin:$PATH"

I then ran Emacs to view those files and copy them into this email, and
started an xterm to test xmonad.hs as below.

>   3. You can also try loading your xmonad.hs in ghci to see whether
>      there are any errors: cd into ~/.xmonad and type 'ghci'; then at
>      the ghci prompt type ':load xmonad.hs'.

I get the following output:

*****ghci, :load xmonad.hs*****
Prelude> :load xmonad.hs
Ok, modules loaded: Main.
Prelude Main>

> If nothing likely comes out of any of these, then we'll have to go
> back to the drawing board.

Could those createFontSet errors maybe indicate something going wrong with
the fonts used to decorate the windows?


More information about the xmonad mailing list