[xmonad] Stuck inside a window - this happen to anyone else?

Brent Yorgey byorgey at gmail.com
Fri Dec 14 11:51:54 EST 2007

On Dec 14, 2007 11:23 AM, Dougal Stanton <ithika at gmail.com> wrote:

> This is just a complete shot-in-the-dark bug report, to see if anyone
> else has experienced similar symptoms. I don't imply that the
> following problem has anything to do with xmonad, though it would seem
> the prime suspect.
> Earlier today I was working in Firefox with a bunch of other windows
> open on screen, a bunch of other workspaces populated too. FF was
> working fine, but everything I tried to do *outside* of the browser
> didn't work. I couldn't mouse over other windows to give them focus. I
> couldn't switch to other workspaces. I couldn't move the focussed
> window around with mod-shift-j/k or choose a new master.
> I couldn't mod-q to restart, though I managed to switch to another
> virtual terminal and back (ctrl-alt-Fn) so the keyboard seems to have
> been responsive. If I'd been thinking at the time I would have tried
> to open another window from within Firefox to see what it would do. In
> the end I killed xmonad from the other VT and it all worked out fine.
> Has this ever happened to you? And secondarily, is there a way to
> mod-q Xmonad through a kill sig? Does it recognise SIGHUP?
> Cheers,
> D.

That sounds like something I've experienced.  Firefox still responded to the
keyboard and mouse, right?  Next time it happens, try opening another window
from within firefox -- when I've experienced this sort of thing, opening
another window has fixed the problem.  Very strange, at any rate...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/xmonad/attachments/20071214/2ff2e5ef/attachment.htm

More information about the xmonad mailing list