[web-devel] Call for comments: Yesod 0.2

Arie Peterson ariep at xs4all.nl
Sat May 22 17:44:48 EDT 2010

On Sat, 22 May 2010 20:42:51 +0300, Michael Snoyman <michael at snoyman.com>
> [...]
> Note: right now it depends on web-routes-quasi 0.3.0, which has not yet
> been
> released, so you'll have to pull that from the github repo.

In order to test my proposed solution (see below), I tried building
web-routes-quasi 0.3.0 from git, but I get another cabal version conflict

| Resolving dependencies...
| cabal: cannot configure template-haskell- It requires base >=4.2
&& <5
| For the dependency on base >=4.2 && <5 there are these packages:
| and base- However none of them are available.
| base- was excluded because of the top level dependency base -any
| base- was excluded because of the top level dependency base -any

I assume this means that it needs ghc 6.12 (which I haven't installed
yet). Do you really need template-haskell-2.4.*, or would 2.3.* suffice as
well? In that case you could relax the version constraint.

> On Sat, May 22, 2010 at 7:32 AM, James Britt <james at neurogami.com>
>> james at james06:~/data/vendor/yesod$ runhaskell Setup.lhs configure
>> Configuring yesod-0.2.0...
>> Warning: This package indirectly depends on multiple versions of the
>> package. This is highly likely to cause a compile failure.
>> package http-wget-0.6.2 requires transformers-
>> package control-monad-attempt-0.3.0 requires transformers-
>> package authenticate-0.6.2 requires transformers-
>> package yesod-0.2.0 requires transformers-
>> package MonadCatchIO-transformers- requires transformers-
>> [...]
>> Suggestions?

>From a quick look at the source of yesod, it /seems/ that it may work with
MonadCatchIO-transformers-0.1.* as well. Is there any reason yesod asks for
>=0.2.2 ? If not, relaxing this version constraint might fix things.



More information about the web-devel mailing list