Monad of no `return` Proposal (MRP): Moving `return` out of `Monad`

Christopher Allen cma at
Sat Sep 26 00:00:23 UTC 2015


The name pure is pretty awful. It's not _that_ big of a deal, but pure is
annoyingly senseless and my coauthor noticed this of her own accord as well.

+1 for the proposal, just wish it wasn't named pure ;)

On Fri, Sep 25, 2015 at 6:47 PM, wren romano <wren at>

> On Fri, Sep 25, 2015 at 1:23 AM, Bardur Arantsson <spam at>
> wrote:
> > Reasoning: I happen to rather like "return" for purely pedagogical
> > purposes since it lets you pretend (as a sufficient-for-beginners
> > approximation) that code in the do-notation in IO is imperative code and
> > "return" is the usual name for what it does in that context. I think
> > that has a certain value, but "Legacy" is quite off-putting.
> +1.
> I like the proposal to merge pure/return into a single thing, but I
> rather prefer the name "return" for all the same pedagogical reasons
> it was originally chosen.
> --
> Live well,
> ~wren
> _______________________________________________
> Libraries mailing list
> Libraries at

Chris Allen
Currently working on
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list