Monad of no `return` Proposal (MRP): Moving `return` out of `Monad`
david.feuer at gmail.com
Sat Sep 26 00:26:56 UTC 2015
I think they're both wretched. return makes beginners think it's a control
structure; pure just seems meaningless (I guess that's a slight
improvement, arguably). I'd have gone for something like inject myself, but
there's no way that's happening.
On Sep 25, 2015 8:00 PM, "Christopher Allen" <cma at bitemyapp.com> wrote:
> The name pure is pretty awful. It's not _that_ big of a deal, but pure is
> annoyingly senseless and my coauthor noticed this of her own accord as well.
> +1 for the proposal, just wish it wasn't named pure ;)
> On Fri, Sep 25, 2015 at 6:47 PM, wren romano <wren at community.haskell.org>
>> On Fri, Sep 25, 2015 at 1:23 AM, Bardur Arantsson <spam at scientician.net>
>> > Reasoning: I happen to rather like "return" for purely pedagogical
>> > purposes since it lets you pretend (as a sufficient-for-beginners
>> > approximation) that code in the do-notation in IO is imperative code and
>> > "return" is the usual name for what it does in that context. I think
>> > that has a certain value, but "Legacy" is quite off-putting.
>> I like the proposal to merge pure/return into a single thing, but I
>> rather prefer the name "return" for all the same pedagogical reasons
>> it was originally chosen.
>> Live well,
>> Libraries mailing list
>> Libraries at haskell.org
> Chris Allen
> Currently working on http://haskellbook.com
> Libraries mailing list
> Libraries at haskell.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Libraries