Monad of no `return` Proposal (MRP): Moving `return` out of `Monad`

wren romano wren at
Fri Sep 25 23:47:59 UTC 2015

On Fri, Sep 25, 2015 at 1:23 AM, Bardur Arantsson <spam at> wrote:
> Reasoning: I happen to rather like "return" for purely pedagogical
> purposes since it lets you pretend (as a sufficient-for-beginners
> approximation) that code in the do-notation in IO is imperative code and
> "return" is the usual name for what it does in that context. I think
> that has a certain value, but "Legacy" is quite off-putting.


I like the proposal to merge pure/return into a single thing, but I
rather prefer the name "return" for all the same pedagogical reasons
it was originally chosen.

Live well,

More information about the Libraries mailing list