illissius at gmail.com
Tue Jun 12 16:30:06 CEST 2012
On Tue, Jun 12, 2012 at 3:37 PM, Gábor Lehel <illissius at gmail.com> wrote:
> On Tue, Jun 12, 2012 at 2:26 PM, Simon Marlow <marlowsd at gmail.com> wrote:
>>> - Can we find a more accurate name for tryWait? It doesn't try and
>>> possibly fail to wait, it avoids waiting altogether. Maybe don'tWait,
>>> although that doesn't say what it does do. The only other idea I have
>>> is 'check' which is not very descriptive...
>> Good point. How about "poll"?
> Definitely better.
- waitAny and company could be generalized to any Foldable. Downside:
it makes the type signatures less obvious. Upside: if people will be
taking the completed Async and removing it from the list (and doing
this frequently), they might prefer something more efficient than a
- If we want to follow the analogy, waitAny could be called 'select'.
More information about the Libraries