ross at soi.city.ac.uk
Thu Jun 14 17:00:42 CEST 2012
On Tue, Jun 12, 2012 at 11:58:41AM +0100, Simon Marlow wrote:
> There's one more change I'm thinking about: perhaps instead of
> wait :: Async a -> IO (Either SomeException a)
> waitThrow :: Async a -> IO a
> we should reverse the naming scheme, rename waitThrow to wait and wait
> to something else (waitCatch?). Rationale: waitThrow seems to be the
> version we need most often, and it's simpler to use.
> wait :: Async a -> IO a
> waitCatch :: Async a -> IO (Either SomeException a)
> Thoughts? Better names for waitCatch?
Perhaps the recently freed tryWait would be analogous with
More information about the Libraries