Hackage compilation problem

Brent Yorgey byorgey at seas.upenn.edu
Sun Sep 5 14:03:31 EDT 2010

On Sun, Sep 05, 2010 at 07:20:52PM +0200, Dominique Devriese wrote:
> Hi all,
> I am working on a new package to be released on Hackage
> (grammar-combinators, release not yet announced). It compiles fine on
> my system (debian testing, special purpose test user with a pristine
> ~/.cabal), but the Hackage build log shows the below error message
> (full version on
> http://hackage.haskell.org/packages/archive/grammar-combinators/0.1/logs/failure/ghc-6.12).
> It seems this error is caused by a transitive dependency (the random
> package) requiring two versions of the time package (?), which does
> not show in that package's .cabal file. I cannot reproduce the problem
> locally and have no idea what might be causing them. I would much
> appreciate it if anyone with some more cabal/hackage experience could
> take a look and comment on the issue.

Unfortunately Hackage uses a somewhat braindead build environment (I
forget the exact details) and so you sometimes get spurious build
errors like this.  If it compiles fine on your system it is probably
OK.  If you want to be absolutely sure that your library will build
properly for other people I recommend using Capri [1].


[1] http://www.haskell.org/haskellwiki/Capri

More information about the Libraries mailing list