HUnit in Hackage

Duncan Coutts duncan.coutts at
Wed Oct 22 17:45:21 EDT 2008

On Tue, 2008-10-21 at 16:53 -0700, Jon Strait wrote:
> Just some quick user feedback/questions.
> The current HUnit in Hackage depends on base (==4.*).  I'm running  GHC
> 6.8.3 with base   Is there an easier way to upgrade base
> without rebuilding GHC?  Otherwise, the Cabal upgrade refuses to work
> unless I uninstall my older HUnit completely, do the Cabal upgrade, then
> re-install the older HUnit.  I have other packages which depend on
> HUnit, so this must be done every time.  Or is there a way to tell Cabal
> Install that I want to mask off HUnit for upgrading when I do a Cabal
> upgrade?

I've updated the hunit package so that the latest version will build
with either base 3 or 4 (ie with ghc-6.8 or 6.10).

I'll upload that to hackage soon. In the mean time use the older version
of hunit eg:

cabal install 'hunit <'

In future I'll try to make cabal-install a bit cleverer so that when the
latest version obviously cannot be installed then it'll consider older
versions too (but not full backtracking). This should help users who are
using an older generation of packages.


More information about the Libraries mailing list