Text.ParserCombinators.* is a bad name

Malcolm Wallace Malcolm.Wallace at cs.york.ac.uk
Wed Mar 8 07:27:43 EST 2006

Ross Paterson <ross at soi.city.ac.uk> wrote:
> >     Text.ParserCombinators.Parsec
> > namespace should be deprecated in favour of:
> >     Text.Combinators.Parsec
> If you want to make them shorter, it's the redundant "Combinators"
> that should go.

Is there not a valid distinction between a Parser library (e.g. for XML
documents), and a ParserCombinator library (which enables one to write
parsers)?  Is it helpful to blur the boundaries between the glue and the
things being glued?

> While we're complaining about module names, how about
> System.Console.GetOpt?

What is wrong with it?  (Not a rhetorical question - I really can't

Ketil Malde wrote:
> I've never understood why there is a need for a deep, sparse hierarchy.

Really, it is just a social mechanism to encourage developers to come up
with long, descriptive names.  You could just as easily drop the dots
and have
with almost no technical impact.  But lots of people would complain
about the amount of letters to type if that was the scheme, and somehow,
if we use dots, it lessens the resistance.  :-)  I'm sure, without dots,
we would still be stuck with lots of short module names in every
project, clashing with everyone elses libraries.


More information about the Libraries mailing list