Text.ParserCombinators.* is a bad name

Ross Paterson ross at soi.city.ac.uk
Wed Mar 8 04:30:02 EST 2006

On Wed, Mar 08, 2006 at 04:42:08PM +1100, Donald Bruce Stewart wrote:
> * Firstly, a library naming issue. Text.ParserCombinators feels like a
> clunkey name. This week I was working on a set of regex combinators,
> that ideally would go under:
>     Text.Combinators.Regex
> but we're stuck with Text.ParserCombinators.Regex. Making me think that:
>     Text.ParserCombinators.ReadP
>     Text.ParserCombinators.Parsec
>     Text.PrettyPrint.HughesPJ
> namespace should be deprecated in favour of:
>     Text.Combinators.ReadP
>     Text.Combinators.Parsec
>     Text.Combinators.HughesPJ

If you want to make them shorter, it's the redundant "Combinators" that
should go.

While we're complaining about module names, how about System.Console.GetOpt?

More information about the Libraries mailing list