DData revision (isSubsetOf / shorter names)
Iavor S. Diatchki
diatchki at cse.ogi.edu
Tue Mar 16 09:08:35 EST 2004
i don't want to get involved in that (thanks for doing it guys!)
i prefer the shorter names likes "empty", "subset" and "elem",
without the "is" and "Of" (simply a metter of taste).
the list module is not very consistent in the naming, so while it may be
to be compatable with it, i woun't go too far with that. for example,
names like "null" and "nub" could probably be improved.
Simon Marlow wrote:
>>JP Bernardy wrote:
>>Now, where "isEmpty" is replaced by "null", I'ld rather see "subset"
>>instead of "isSubsetOf", particularly also because
>>"isProperSubsetOf" is so long.
>I vote for consistently using isXXXX for predicates.
>Libraries mailing list
>Libraries at haskell.org
More information about the Libraries