DData revision (isSubsetOf / shorter names)

JP Bernardy jyp_7 at yahoo.com
Tue Mar 16 09:19:03 EST 2004

> the list module is not very consistent in the
> naming, so while it may be 
> nice
> to be compatable with it, i woun't go too far with
> that.

I expect most haskellers to know the List module
inside out. So they'll propably be confortable with
something very close to it.

Additionally, lists cannot be discarded, so we'll have
to keep the list module. Having to remember two sets
of conventions would not please me.

> for example,
> names like "null" and "nub" could probably be
> improved.

If anything has to be improved, let it be the list
module, and the rest would follow.


Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam

More information about the Libraries mailing list