DData revision (isSubsetOf / shorter names)
jyp_7 at yahoo.com
Tue Mar 16 04:14:47 EST 2004
> > Now, where "isEmpty" is replaced by "null", I'ld
> rather see "subset"
> > instead of "isSubsetOf", particularly also because
> > "isProperSubsetOf" is so long.
> I vote for consistently using isXXXX for predicates.
Maybe I should remind the main guideline I used for
naming: follow the naming scheme of "Data.List" as
close as possible, for maximal consistency inside
This justifies "isSubsetOf" (modelled after
"isPrefixOf"), and "null".
I notice that "null" is not classified as a predicate
in Data.List documentation. "isEmpty" can always be
added, but then, it would be logical to add such a
function for lists too.
Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam
More information about the Libraries