Alternative hierarchy proposal.

Simon Marlow
Wed, 28 Feb 2001 06:33:14 -0800

> Please mind the "style warning"
> > 	   MArray		-- (opt)
> > 	   IOArray		-- mutable arrays in the IO/ST monads
> MArray looks cryptic. Why not Array.Mutable, and similar.
> There are a few more places where this applies.
> Of course this is rather irrelevant to the layout discussion now.
> But perhaps not, since it's the question of introducing
> small sub-modules, or using name prefixes.

Good point.  However, this scheme is following another style guideline,
which is that the module name follows the type name, when the module
defines a type.  Perhaps the MArray type should also be renamed to
Mutable (i.e. Haskell.Lang.Array.Mutable qualified), but this doesn't
look as nice.