Alternative hierarchy proposal.

Johannes Waldmann
Wed, 28 Feb 2001 19:16:47 +0100 (MET)

> Good point.  However, this scheme is following another style guideline,
> which is that the module name follows the type name, when the module
> defines a type. 

Yes this is a good principle, and it should be kept.

> Perhaps the MArray type should also be renamed 

That was my intention.

> to Mutable (i.e. Haskell.Lang.Array.Mutable qualified), but this doesn't
> look as nice.

So what about ...Mutable.Array, then? The type name would be `Array'. 

What we're in fact trying to do here, roughly,
is to give different implementations of one interface.
Well, it's not exactly the same, but still these are Arrays.

The Edison user guide gives a good discussion of similar design decisions.

-- Johannes Waldmann ---- --
-- -- phone/fax (+49) 341 9732 204/252 --