[Haskell] ANN: Yi

Colin Paul Adams colin at colina.demon.co.uk
Wed Mar 24 15:27:25 EDT 2010

>>>>> "Jeff" == Jeff Wheeler <jeff at nokrev.com> writes:

    Jeff> On Wed, Mar 24, 2010 at 2:03 PM, Colin Paul Adams
    Jeff> <colin at colina.demon.co.uk> wrote:

> Is it for ghc 6.12 only?

    Jeff> I guess so. 6.12 requires template-haskell ==2.4, and I
    Jeff> couldn't get Yi to compile without explicitly adding this into
    Jeff> its cabal file.  There may be a way to set the dependencies to
    Jeff> work for both, but I don't see how.

Hm. I edited the cabal file to allow >= 2.3 && < 2.5 and it just
compiled. Wouldn't this work with 6.12 also? 
Colin Adams
Preston Lancashire

More information about the Haskell mailing list