[Haskell] ANN: Yi

Jeff Wheeler jeff at nokrev.com
Wed Mar 24 15:30:25 EDT 2010

On Wed, Mar 24, 2010 at 2:27 PM, Colin Paul Adams
<colin at colina.demon.co.uk> wrote:

> Hm. I edited the cabal file to allow >= 2.3 && < 2.5 and it just
> compiled. Wouldn't this work with 6.12 also?

Unfortunately not. Making that change yields:

yi$ cabal install
Resolving dependencies...
cabal: dependencies conflict: ghc-6.12.1 requires template-haskell ==
template-haskell- was excluded because data-accessor-template-
requires template-haskell >=2.2 && <2.4

data-accessor-template needs to be compiled with the -ftemplate_2_4
flag, which Cabal doesn't try here, for some reason.

Jeff Wheeler

Undergraduate, Electrical Engineering
University of Illinois at Urbana-Champaign

More information about the Haskell mailing list