[Haskell] ANN: Yi

Colin Paul Adams colin at colina.demon.co.uk
Wed Mar 24 15:03:55 EDT 2010

>>>>> "Jeff" == Jeff Wheeler <jeff at nokrev.com> writes:

    Jeff> Hi everybody, I'm very excited to announce the first release
    Jeff> of Yi in nearly a year. For most of this time, Yi has been
    Jeff> rather tough to install because of the mess of dependencies.

    Jeff> Today these issues were resolved, and I uploaded a new package
    Jeff> to Hackage, so installing Yi should be as simple as:

    Jeff> $ cabal update $ cabal install yi

Not here. I get:

cabal: dependencies conflict: ghc-6.10.4 requires template-haskell ==
template-haskell- was excluded because template-haskell- was
selected instead
template-haskell- was excluded because data-accessor-template-
requires template-haskell ==2.4.*
template-haskell- was excluded because yi- requires
template-haskell ==2.4.*

Is it for ghc 6.12 only?
Colin Adams
Preston Lancashire

More information about the Haskell mailing list