[Haskell] ANNOUNCE: Sifflet visual programming language, release 0.1.7

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Fri Jun 11 10:22:05 EDT 2010

Henning Thielemann <lemming at henning-thielemann.de> writes:

> gdweber at iue.edu schrieb:
>> Sifflet 0.1.7 is now available on Hackage.
>> This release has some changes in its package dependencies,
>> notably for fgl.
>> New in This Release
>> -------------------
>> -   Due to anticipated changes in the API for fgl,
>>     Sifflet now requires fgl <
>> -   Similarly, I have added upper bounds on versions
>>     of some other packages that Sifflet depends on.
> I'm uncertain whether fgl conforms to the package versioning policy, but
> if it does, then changes in its Cabal file should not bother sifflet.
> Thus upper bound fgl < 5.4.3 should be restrictive enough.

Well, it definitely will be following the PVP from now on.  As for that
restriction, it doesn't make any difference; we might make a 5.5
transition/compatability release at some point but that's about it.

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the Haskell mailing list