Any versions of Fudgets working with GHC-6?

Henrik Berg henrikbe at
Wed Jan 21 21:34:27 EST 2004

Henrik Berg <henrikbe at> writes:

> Hi!
> I've been trying for a while now to install the Fudget GUI library
> (,
> but with no luck so far.  I've tried many different versions,
> both source and binary, but it seems like there's some kind of
> dependency or something that I don't know of, the sources won't
> compile and the binaries won't run...
> My system is linux (RedHat 7.1), ghc version 6.0.1.  Does anyone know
> how/where I can get a working version of Fudgets, without too many
> version problems/dependency problems etc etc?

YESSSS!  Suddenly, it worked...!!

Seems like I had two GHC-versions on my system at once (6.0.1 and
5.04.3).  I was able to compile Fudgets when I removed 6.0.1, using
only 5.04.3.

Still don't understand why I coudn't get it compile with 6.0.1,
though.  But, who cares, I got it working at last!

Sorry for bothering you all,

More information about the Haskell mailing list