[Haskell-cafe] Yesod devel issue: cannot satisfy -package-key main

Geraldus heraldhoi at gmail.com
Mon Jan 16 02:34:02 UTC 2017

Hi folks!

I haven't used Yesod quite a while; now when I'm trying to run development
server of freshly scaffolded PostgreSQL stack's template I see this error

Rebuilding application... (using cabal)
Starting development server...
*<command line>: cannot satisfy -package-key main*
    (use -v for more information)
Exit code: ExitFailure 1

I've found several issues on the web, however I wasn't able to resolve this.

I've tried to upgrade my Yesod binary first via `stack install yesod-bin`.
I have:

stack exec yesod version
*yesod-bin version:*

stack --version
*Version 1.1.2 x86_64 hpack-0.14.0*

I also tried to comment out the test suite section in cabal file, but devel
server still fails to run.

Can someone clarify how to deal with this?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20170116/e641ead4/attachment.html>

More information about the Haskell-Cafe mailing list