[Haskell-cafe] Yesod devel issue: cannot satisfy -package-key main

Michael Snoyman michael at snoyman.com
Mon Jan 16 05:52:42 UTC 2017

Can you try upgrading to yesod-bin-1.5.0? Some of the issues with the old
yesod-bin are documented at:


Looking at that error message, I'm going to take a (very bad) guess and say
you're using GHC 8. If that's the case, yesod-bin 1.4 is definitely _not_
compatible with it.

On Mon, Jan 16, 2017 at 4:34 AM, Geraldus <heraldhoi at gmail.com> wrote:

> Hi folks!
> I haven't used Yesod quite a while; now when I'm trying to run development
> server of freshly scaffolded PostgreSQL stack's template I see this error
> message:
> Rebuilding application... (using cabal)
> Starting development server...
> *<command line>: cannot satisfy -package-key main*
>     (use -v for more information)
> Exit code: ExitFailure 1
> I've found several issues on the web, however I wasn't able to resolve
> this.
> I've tried to upgrade my Yesod binary first via `stack install
> yesod-bin`.  Now
> I have:
> stack exec yesod version
> *yesod-bin version:*
> stack --version
> *Version 1.1.2 x86_64 hpack-0.14.0*
> I also tried to comment out the test suite section in cabal file, but devel
> server still fails to run.
> Can someone clarify how to deal with this?
> _______________________________________________
> Haskell-Cafe mailing list
> To (un)subscribe, modify options or view archives go to:
> http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
> Only members subscribed via the mailman list are allowed to post.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20170116/a10018cb/attachment.html>

More information about the Haskell-Cafe mailing list