[Haskell-cafe] Trying to install hpodder on OS X Lion

Antoine Latter aslatter at gmail.com
Fri Oct 21 17:20:18 CEST 2011

On Fri, Oct 21, 2011 at 9:32 AM, seanh <snhmnd at gmail.com> wrote:
> I'd really like to get hpodder installed on OS X Lion, I can't find it
> packaged anywhere (macports, homebrew...) Has anyone got it working?
> I have the haskell platform installed from the pkg file from haskell.org:
> http://hackage.haskell.org/platform/mac.html
> So I tried `cabal install hpodder` but it failed. First I get a lot of
> warnings like:


I don't know much about these, but they are unrelated to the error bellow.

> Here's the error from the compiler before that:
> Commands/SetStatus.hs:59:33:
>    Ambiguous type variable `e0' in the constraint:
>      (E.Exception e0) arising from a use of `E.catch'
>    Probable fix: add a type signature that fixes these type variable(s)


The exceptions API changed in GHC 6.10, and the 'hpodder' package on
hackage hasn't been updated to accommodate those changes.

It looks like the version up on github should no longer have this error:

It may have other errors, though - I haven't tried it :-)


More information about the Haskell-Cafe mailing list