[Haskell-cafe] Problem installing wxHaskell on Haskell Platform on OSX.

David Place d at vidplace.com
Wed Mar 10 17:14:16 EST 2010


I have just installed the Haskell Platform 2009.2.0.2 on Mac OSX 10.6.2.  When I try to install wx I get the following error which I do not understand.
Can anyone give me a hint?

$ cabal install wx
Resolving dependencies...
cabal: cannot configure containers- It requires base >=4.2 && <6
For the dependency on base >=4.2 && <6 there are these packages: base-
However none of them are available.
base- was excluded because of the top level dependency base -any

Here are my packages:

$ ghc-pkg list
   Cabal-, GLUT-, HTTP-4000.0.6, HUnit-,
   OpenGL-, QuickCheck-, array-, base-,
   base-, bytestring-, cgi-3001.1.7.1,
   containers-, directory-, (dph-base-0.3),
   (dph-par-0.3), (dph-prim-interface-0.3), (dph-prim-par-0.3),
   (dph-prim-seq-0.3), (dph-seq-0.3), editline-,
   extensible-exceptions-, fgl-, filepath-,
   (ghc-6.10.4), ghc-prim-, haddock-2.4.2, haskell-src-,
   haskell98-, hpc-, html-, integer-,
   mtl-, network-, network-, old-locale-,
   old-time-, packedstring-, parallel-,
   parsec-, pretty-, process-, random-,
   regex-base-, regex-compat-, regex-posix-,
   rts-1.0, stm-, syb-, template-haskell-,
   time-, time-1.1.4, unix-, xhtml-3000.2.0.1,

More information about the Haskell-Cafe mailing list