[Haskell-cafe] Hackage Package version ranges

Jesper Louis Andersen jesper.louis.andersen at gmail.com
Wed Feb 3 07:57:30 EST 2010

On Wed, Feb 3, 2010 at 2:13 AM, Ivan Lazar Miljenovic
<ivan.miljenovic at gmail.com> wrote:
> Well, in Gentoo we normally resort to using sed to fix these kinds of
> things.  If we can do it, I'm sure the Arch package managers are able to
> do so.
> It might be more annoying, but IMHO it's a bigger problem when a
> developer is too lax in constraints (since then we've got to tweak the
> constraints until we find ones that _do_ work).

That is not a bad idea. The only problem I can see with that approach
is the error-reports will be hard to understand if they are not
filtered through the maintainer of said Gentoo-package. I usually
configure my git-repositories to use 'git describe' and add a -dirty
or -tainted to that if the tree is not clean when building. This tend
to capture the problem of local patches and gives me a hint that
something is altered :)


More information about the Haskell-Cafe mailing list