[Haskell-cafe] Hackage Package version ranges

Neil Mitchell ndmitchell at gmail.com
Tue Feb 2 17:32:00 EST 2010

>> Alternatively, if I could sign up to be emailed when something went
>> wrong, I'd happily fix it. i.e. I'd like an email either when my
>> package fails to compile against the latest version of all packages
>> but within my constrained range, or when the latest version falls
>> outside my constraint range.
> Getting correct dependency convergence through automatic building of
> packages and error-emails would be fairly interesting I think. The
> problem is not new as all software with dependencies are bound to run
> against its wall at some point - so perhaps there are some thoughts
> out there about what works and what doesn't.

Note that giving an error message when the latest constrained version
fails to build is really hard, and requires building the package. An
email simply saying "you say cpphs-1.10.* which excludes the most
recent one which is cpphs-1.11" just requires parsing the cabal files,
and is much easier. It's not as useful, but it might be a useful first

Thanks, Neil

More information about the Haskell-Cafe mailing list