[Haskell-cafe] I can't install hs-plugins beceause of Linker.h

Don Stewart dons at galois.com
Sun Mar 15 02:04:30 EDT 2009

It depends on if you need 'eval' or object loading capability.

For true plugins, hs-plugins is still the only binding to the GHC rts
object loader, for eval-like mechanisms, we've a number of bindings to
the ghc-api bytecode interpreter, such as hint.

That said, hs-plugins is kinda sorta patches-applied maintained.

> I believe that hs-plugins has fallen out of use, on #haskell, I was  
> directed to hint[1]. IIRC, I had to disable some packages because of  
> cross installation.
> /Joe
> [1] http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hint
> Yuri Kashnikoff wrote:
>> Hi!
>> I was trying to install hs-plugins both from sources "$./Setup.lhs
>> ..." and with "$cabal fetch&&cabal install" and both failed.
>> It always reports that Linker.h is missing. I have tried to use
>> --extra-include-dirs with path to ghc-6.10.1 dir and
>> ghc-6.10.1/include dir. Nothing changed.
>> Here is a report from Setup.lhs:
>> Setup.lhs:2:2:
>>     Warning: In the use of `defaultUserHooks'
>>              (imported from Distribution.Simple):
>>              Deprecated: "Use simpleUserHooks or autoconfUserHooks,
>> unless you need Cabal-1.2
>>              compatibility in which case you must stick with defaultUserHooks"
>> Warning: defaultUserHooks in Setup script is deprecated.
>> Configuring plugins-1.4.0...
>> Warning: This package indirectly depends on multiple versions of the same
>> package. This is highly likely to cause a compile failure.
>> package ghc-6.10.1 requires Cabal-
>> package plugins-1.4.0 requires Cabal-
>> checking build system type... i386-apple-darwin9.6.0
>> checking for ghc... ghc
>> checking for value of __GLASGOW_HASKELL__... 610
>> checking for ghc library directory... /opt/local/lib/ghc-6.10.1/.
>> checking for gcc... gcc
>> checking for C compiler default output file name... a.out
>> checking whether the C compiler works... yes
>> checking whether we are cross compiling... no
>> checking for suffix of executables...
>> checking for suffix of object files... o
>> checking whether we are using the GNU C compiler... yes
>> checking whether gcc accepts -g... yes
>> checking for gcc option to accept ANSI C... none needed
>> checking for arc4random... yes
>> checking for a BSD-compatible install... /usr/bin/install -c
>> configure: creating ./config.status
>> config.status: creating config.mk
>> config.status: creating testsuite/makewith/io/TestIO.conf
>> config.status: creating testsuite/makewith/unsafeio/Unsafe.conf
>> config.status: creating config.h
>> config.status: config.h is unchanged
>> Setup.lhs: Missing dependency on a foreign library:
>> * Missing header file: Linker.h
>> This problem can usually be solved by installing the system package that
>> provides this library (you may need the "-dev" version). If the library is
>> already installed but in a non-standard location then you can use the flags
>> --extra-include-dirs= and --extra-lib-dirs= to specify where it is.

> begin:vcard
> fn:Joseph Fredette
> n:Fredette;Joseph
> adr:Apartment #3;;6 Dean Street;Worcester;Massachusetts;01609;United States of America
> email;internet:jfredett at gmail.com
> tel;home:1-508-966-9889
> tel;cell:1-508-254-9901
> x-mozilla-html:FALSE
> url:lowlymath.net, humbuggery.net
> version:2.1
> end:vcard

> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list