[Haskell-cafe] I can't install hs-plugins beceause of Linker.h

Joe Fredette jfredett at gmail.com
Sun Mar 15 02:00:05 EDT 2009

I believe that hs-plugins has fallen out of use, on #haskell, I was 
directed to hint[1]. IIRC, I had to disable some packages because of 
cross installation.


[1] http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hint

Yuri Kashnikoff wrote:
> Hi!
> I was trying to install hs-plugins both from sources "$./Setup.lhs
> ..." and with "$cabal fetch&&cabal install" and both failed.
> It always reports that Linker.h is missing. I have tried to use
> --extra-include-dirs with path to ghc-6.10.1 dir and
> ghc-6.10.1/include dir. Nothing changed.
> Here is a report from Setup.lhs:
> Setup.lhs:2:2:
>     Warning: In the use of `defaultUserHooks'
>              (imported from Distribution.Simple):
>              Deprecated: "Use simpleUserHooks or autoconfUserHooks,
> unless you need Cabal-1.2
>              compatibility in which case you must stick with defaultUserHooks"
> Warning: defaultUserHooks in Setup script is deprecated.
> Configuring plugins-1.4.0...
> Warning: This package indirectly depends on multiple versions of the same
> package. This is highly likely to cause a compile failure.
> package ghc-6.10.1 requires Cabal-
> package plugins-1.4.0 requires Cabal-
> checking build system type... i386-apple-darwin9.6.0
> checking for ghc... ghc
> checking for value of __GLASGOW_HASKELL__... 610
> checking for ghc library directory... /opt/local/lib/ghc-6.10.1/.
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ANSI C... none needed
> checking for arc4random... yes
> checking for a BSD-compatible install... /usr/bin/install -c
> configure: creating ./config.status
> config.status: creating config.mk
> config.status: creating testsuite/makewith/io/TestIO.conf
> config.status: creating testsuite/makewith/unsafeio/Unsafe.conf
> config.status: creating config.h
> config.status: config.h is unchanged
> Setup.lhs: Missing dependency on a foreign library:
> * Missing header file: Linker.h
> This problem can usually be solved by installing the system package that
> provides this library (you may need the "-dev" version). If the library is
> already installed but in a non-standard location then you can use the flags
> --extra-include-dirs= and --extra-lib-dirs= to specify where it is.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jfredett.vcf
Type: text/x-vcard
Size: 296 bytes
Desc: not available
Url : http://www.haskell.org/pipermail/haskell-cafe/attachments/20090315/3f892e98/jfredett-0001.vcf

More information about the Haskell-Cafe mailing list