[Haskell-cafe] Looking for Haskellers on Windows

Günther Schmidt redcom at fedoms.com
Sat Jan 10 11:09:03 EST 2009

Hi Kyra,

and again, thanks for taking the effort.

Kyra I've tried any sort of values to any sort of columns. I tried "insert  
into somesinglecolumntable (someNumbercolumn) values (?)" [toSql 5] ...  
and so on.

So I'm not certain at all the error message does actually give the right  

It just blows no matter what.

What does work though is this:

	run dbc "insert into sometable (someVarcharcolumn) values ('some string  
value')" []

This would be a workaround for my app, but I hope I can do better.


Am 10.01.2009, 17:01 Uhr, schrieb kyra <kyrab at mail.ru>:

> Günther Schmidt wrote:
>> Hi Kyra,
>>  thanks for your reply.
>>  The problem I was facing is using an MS-Access backend with HDBC-ODBC.  
>> I try to export data to MS-Access and I can't get it to work. Otherwise  
>> HDBC works fine in other parts of my app but with MS-Access it blows up.
>>  I did of course post this on the haskell-cafe list first, but no  
>> response and the HDBC package maintainer himself was unable to help too  
>> since he's not using Windows.
> I've looked at Your problem now. What is the type of that single field  
> in 'mytable'? Google shows numerous similar cases, e.g. for date or memo  
> fields, that Access don't accept varchars and require longvarchars for.
> I'm in no way an Access expert.
> Cheers,
> Kyra

Erstellt mit Operas revolutionärem E-Mail-Modul: http://www.opera.com/mail/

More information about the Haskell-Cafe mailing list