[Haskell-cafe] cabal upgrade

Martin DeMello martindemello at gmail.com
Wed Oct 1 16:24:55 EDT 2008

On Wed, Oct 1, 2008 at 1:06 PM, Gwern Branwen <gwern0 at gmail.com> wrote:

> Yi fails on Alex because Cabal doesn't track executables, nor executables needed for installation. You want 'cabal install alex yi';

Yay, that finally worked :) Had to add ~/.cabal/bin to my path first,
which wasn't hard to figure out but should probably also be in a faq

> I believe the FAQ covers this.

Nope. I was following http://www.haskell.org/haskellwiki/Yi when I got
stuck, and the page makes no mention of how to resolve the alex

> As for cabal install yi-gtk, unless things have changed since I last looked, the answer is Don't Do That. yi-gtk and yi-vty are solely for yi 0.3 and below - it's obsolete, in other words. Yi depends directly on vty (which cabal install will handle) and GTK2HS, which unfortunately is not on Hackage and so you or your distro has to handle that.

Okay, thanks :)


More information about the Haskell-Cafe mailing list