[Haskell-cafe] What to do when GHC works, RUNGHC fails

Alistair Bayley alistair at abayley.org
Fri May 23 04:08:09 EDT 2008

2008/5/22 Peter Verswyvelen <bf3 at telenet.be>:
> The first thing I noticed is that RUNGHC looks for a DLL called "png.dll"
> (which it doesn't find and then bails out with an error), while the
> executable build with GHC uses the correct "libpng3.dll". When I rename the
> libpng3.dll into png.dll, RUNGHC goes a bit further but then fails with an
> "unknown symbol". Obviously I did something wrong in my Cabal script, but I
> have no idea what it is.
> There seems to be a big difference when it comes to linking between of GHCi
> and GHC . Any guidelines on what to do in cases like the one above?

We had a similar problem with Takusen and ghci on Windows, where the
PostgreSQL client dll is called libpq.dll, rather than pq.dll. We also
solved it by copying pq.dll to libpq.dll. The extra-libs option is pq,
rather than libpq. That fixed it for us, so I don't know why yours is
still failing. Perhaps you can post a link to the src?


More information about the Haskell-Cafe mailing list