[Haskell-cafe] trouble building 6.7 on ubuntu

Thomas Hartman thomas.hartman at db.com
Thu Aug 16 09:39:54 EDT 2007

I have gotten ghc 6.7 to compile, but not with extra libs.  I'm on linux 
x86, ubuntu.

Can someone suggest a download date that worked for them, or how to fix 
one or more of the problems described below?

When I build from source (this is for august 2, unknown linux, as conal 
spoke well of it :) but I have tried with several other dates in august 
with the same result)

I get 

Linux linuxpt 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 

The programs included with the Ubuntu system are free software;
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
Which we'll further canonicalise into: i386-unknown-linux
checking for path to top of build tree... ./configure: line 1433: cd: 
 No such file or directory
./configure: line 1438: -v0: command not found
./configure: line 1441: utils/pwd/pwd: No such file or directory
configure: error: cannot determine current directory

when I try unzip src and extralibs I get 

(aug 15... tail of a large out file after >1.5 hours of configure; make > 

make[1]: Leaving directory 
make -C libraries all
make[1]: Entering directory 
rm -f -f stamp/configure.library.*.base base/unbuildable
( cd base && setup/Setup configure \
                    --enable-library-profiling --enable-split-objs \
                   --prefix='$topdir' \
                   --datadir='$prefix/share/ghc' \
                   --datasubdir='.' \
                   --libsubdir='$compiler/lib/$pkgid' \
                   --with-hsc2hs=../../utils/hsc2hs/hsc2hs-inplace \
                   --with-ld=/usr/bin/ld \
                   --haddock-args="--use-contents=../index.html \
                                   --use-index=../doc-index.html" \
                   --configure-option=--with-cc=gcc ) \
              && touch 
stamp/configure.library.build-profiling-splitting.base || touch 
Setup: Warning: Unknown fields: nhc98-options (line 173)
Fields allowed in this section:
    buildable, cc-options, ld-options, frameworks, c-sources,
    extensions, extra-libraries, extra-lib-dirs, includes,
    install-includes, include-dirs, hs-source-dirs, other-modules,
    ghc-prof-options, ghc-options, hugs-options, nhc-options,
    jhc-options, exposed-modules
Setup: Warning: A package using section syntax should require
"Cabal-Version: >= 1.2" or equivalent.
HsColour 1.6
configure: Reading installed packages...
Configuring base-2.1...
configure: Flags chosen: isghc=True
configure: Dependency rts-any: using rts-1.0
Setup: executing external program failed (exit 1) : 
/usr/local/bin/HsColour -version
rm -f base/GNUmakefile
cp Makefile.local base
if ifBuildable/ifBuildable base; then \
           cd base && setup/Setup makefile -f GNUmakefile; \
Setup: error reading dist/setup-config; run "setup configure" command?

make[1]: *** [base/GNUmakefile] Error 1
make[1]: Leaving directory 
make: *** [stage1] Error 2

very weird error because when I execute /usr/local/bin/HsColour -version 
it doesn't fail but outputs 1.6.

Can somebody suggest a download date known to compile (with extralibs) for 
ubuntu? Or suggest a fix?

By the way I have also tried 

darcs get http://hackage.haskell.org/trac/ghc

but this dies about halfway through (in the patch 10000s ) with libcurl 
error 18 or libcurl error 404 depending on the phase of the moon.

I'm currently trying a build from darcs checkout with get --partial. If 
this is the preferred way of doing a checkout due to "crapping out 
halfway" issues maybe it should be said in the readme. (to be honest I 
forget what the difference between a partial darcs get and a complete get 

Much obliged,


"Conal Elliott" <conal at conal.net> 
Sent by: cvs-ghc-bounces at haskell.org
08/15/2007 06:38 PM

cvs-ghc at haskell.org

Fwd: how to get packages for HEAD snapshot ?

oops -- meant to cc cvs-ghc

btw, 20070802 does run and does have libs included. 

---------- Forwarded message ----------
From: Conal Elliott < conal at conal.net>
Date: Aug 15, 2007 2:56 PM
Subject: Re: how to get packages for HEAD snapshot ?
To: Stefan O'Rear <stefanor at cox.net>

Thank Stefan, 

The latest mingw32 snapshot I see is 20070811.  I installed it also, and 
when I run ghc, it just crashes (WinXP).  Happens when I run it inside of 
emacs and also in a cygwin bash window.

Is that a known problem? 

 - Conal

On 8/15/07, Stefan O'Rear < stefanor at cox.net> wrote:
On Wed, Aug 15, 2007 at 02:20:53PM -0700, Conal Elliott wrote:
> I installed ghc-6.7.20070810-i386-unknown-mingw32.exe.  Though it runs, 
> don't know how to get other packages installed, including Cabal. 
> list" tells me that I have only {ghc-6.7.20070810}, rts-1.0.
> Any suggestions?

Upgrade GHC; Cabal should be installed but wasn't due to a bug in that


Version: GnuPG v1.4.6 (GNU/Linux)


Cvs-ghc mailing list
Cvs-ghc at haskell.org


This e-mail may contain confidential and/or privileged information. If you 
are not the intended recipient (or have received this e-mail in error) 
please notify the sender immediately and destroy this e-mail. Any 
unauthorized copying, disclosure or distribution of the material in this 
e-mail is strictly forbidden.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20070816/16ef03d0/attachment.htm

More information about the Haskell-Cafe mailing list