Unable to compile ghc from darcs

Simon Marlow marlowsd at gmail.com
Tue Mar 31 09:33:14 EDT 2009

Colin Paul Adams wrote:
>>>>>> "Simon" == Simon Marlow <marlowsd at gmail.com> writes:
>     Simon> Are you using a build tree made with lndir?  If you, you
>     Simon> probably want to link the _darcs directory from your source
>     Simon> tree into your build tree.  This will enable configure to
>     Simon> generate a more accurate version number, which will
>     Simon> probably fix the compile problem with Haddock.
>     >> 
>     >> I don't think so. I am just typing ./configure and make within
>     >> the source tree (the parent of the _darcs directory). Is this
>     >> bad?
>     Simon> No, that should be fine.  The Haddock build error indicates
>     Simon> that either your Haddock sources are out of date with
>     Simon> respect to your GHC sources, or Haddock thinks your GHC is
>     Simon> a different version than it really is.
>     Simon> What GHC are you using to bootstrap with, BTW?
> 6.11.20090319 (formerly bootstrapped from 6.10.1).

Ah, there's your problem.  In general you can't bootstrap GHC using a 
development snapshot, we only support building using fixed released versions.


More information about the Glasgow-haskell-users mailing list