compiling GHC with a custom path to GCC

Remi Turk rturk at
Thu Feb 17 06:58:41 EST 2005

On Thu, Feb 17, 2005 at 04:48:54AM -0700, Seth Kurtzberg wrote:
> Simon Marlow wrote:
> >On 17 February 2005 11:12, Remi Turk wrote:
> >
> > 
> >
> >>when compiling the new ghc pre-releases made my gcc 2.95.3 die
> >>with "internal compiler error", I tried to compile it with gcc
> >>3.4.3 (or rather, I thought it compiled with 3.4.1, and when that
> >>died, compiled+installed gcc 3.4.3, tried again, say it die again
> >>and only then noticed it was actually still using 2.95.3 ;) but
> >>had quite some difficulty to actually get it to compile with, in
> >>my case, /usr/local/bin/gcc3
> >>
> >>When using the following command-line
> >>
> >>CC=gcc3 CXX=g++3 nice ./configure --enable-hopengl
> >>--prefix=/var/tmp/ghc --with-gcc=/usr/local/bin/gcc3 
> >>
> >>stage1 still used gcc 2.95.3 to compile stage2 (okay, for --with-gcc
> >>that's documented) 
> >>   
> >>
> >
> >Really?  --with-gcc should set the gcc for stage1, AFAIK.  Is there a
> >bug here?
> >
> >I've noticed gcc 2.95 crashing on my FreeBSD box too.  I should look
> >into whether there's a workaround, otherwise we're hosed on FreeBSD 4.x.
> > 
> >
> This is a known problem in all the 3.x compilers, and also occurs, 
> although less often, with 2.9x versions.  I've seen no difference in 
> frequency comparing FreeBSD to Linux and NetBSD.
> The only solution, which is of course highly annoying, is to simply 
> restart the make.  For whatever reason this always works, sometimes 
> until the end of the build, and sometimes until some other crash.  My 
> theory is that it is related to the temporary files that gcc creates, 
> mostly for templates. 
> While a royal PITA, the resulting code is correct.
> >Cheers,
> >	Simon

I'm afraid finding a workaround for compilers dying on
compiler-generated code isn't going to be much fun...

Anyway, I just replaced a
        ifneq "$(INSTALL_LIBS)" ""
        ifneq "$(strip $(INSTALL_LIBS))" ""
(see my glasgow-haskell-bugs message of today, this usage is
recommended in make's "info" for strip.)

Now I could install ghc, remove the build-tree and get enough
free space to start compiling again.
This time I'll log everything and come back when I'm sure what
exactly is going on. (As I "remember" that 1) --with-gcc doesn't
do what it should and 2) the gcc-2.95-crash on linux seems to be

Nobody can be exactly like me. Even I have trouble doing it.

More information about the Glasgow-haskell-users mailing list