Problems building ghc-current

Volker Stolz
Wed, 28 May 2003 10:29:00 +0200

In local.glasgow-haskell-users, you wrote:
> I'm trying to compile the latest version of GHC from CVS. I followed
> the instructions on GHC's web page and everything worked just fine.
> But when I updated the sources with "cvs update -dP" as instructed,
> CVS checked-out pretty much everything the CVS repository carries. (Is
> that supposed to happen? The CVS cheat sheet suggests that only "ghc",
> "libraries", and "hslibs" would be used/required.)

Where did you find those instructions? The CVS Cheat Sheat is quite clear
on the matter, in fact I couldn't find "-dP" in the entire page.
"-d" (don't  --want to ;)-- know what the "P" does) at least checks out
any subdirectories, which, after getting fpconfig, is indeed the entire
tree :)

After getting fpconfig, 'cvs checkout ghc hslibs libraries' (if you have
'happy' installed, otherwise you need this as well, 'haddock' might be
useful, too). [I guess we should really add those two to the list]

> So, when I tried to compile again -- now with _everything_ in the
> source tee --, the build fails here:

You probably won't need greencard anyway, so maybe it's best to wipe
it from the disk (and all the other unrelated stuff).

Or simply enter the ghc-director 'make boot all', then go to
fptools/libraries, 'make all', and do the same in fptools/hslibs.

-- *** PGP *** S/MIME
rage against the finite state machine