Problems building ghc-current

Peter Simons
28 May 2003 09:18:50 +0200


I'm trying to compile the latest version of GHC from CVS. I followed
the instructions on GHC's web page and everything worked just fine.
But when I updated the sources with "cvs update -dP" as instructed,
CVS checked-out pretty much everything the CVS repository carries. (Is
that supposed to happen? The CVS cheat sheet suggests that only "ghc",
"libraries", and "hslibs" would be used/required.)

So, when I tried to compile again -- now with _everything_ in the
source tee --, the build fails here:

 | ------------------------------------------------------------------------
 | ==fptools== make boot -wr;
 |  in /usr/local/src/ghc-current/green-card/lib
 | ------------------------------------------------------------------------
 | target ffi    Foreign/GreenCard.gc -o Foreign/GreenCard.hs
 | make[2]: target: Command not found
 | make[2]: [Foreign/GreenCard.hs] Error 127 (ignored)

Obviously, at some point the Makefile goes wrong and doesn't get the
options right, but I have no idea where to start looking. Is this a
known problem? Or has anyone a suggestion where to start debugging

I'm building GHC on Linux/i386 with GHC 5.04.3 as boot-strapping
compiler and GCC 3.2.2 as C backend.

Any suggestions are appreciated!