Module Renaming: GHC.Core.Op

Andreas Klebinger klebinger.andreas at
Fri Apr 3 20:26:57 UTC 2020

Hello devs,

While I looked at the renaming a bit when proposed I only just realized
we seem to be using Op as a short name for optimize.

I find this very unintuitive. Can we spare another letter to make this
GHC.Core.Opt instead?

We use opt pretty much everywhere else in GHC already.


More information about the ghc-devs mailing list