build fail with latest 8.1 sources

Simon Peyton Jones simonpj at
Sat Nov 12 23:16:57 UTC 2016

I’ve seen a very recent commit that mentioned bumping a TH bound.  Maybe pull, make clean and try again?


From: ghc-devs [mailto:ghc-devs-bounces at] On Behalf Of John Leo
Sent: 12 November 2016 22:48
To: ghc-devs <ghc-devs at>
Subject: build fail with latest 8.1 sources

Hi everyone,

I'm trying to build the latest 8.1 sources on a Mac running El Capitan.  I'm getting an error I'd never seen before and wonder if anyone has any pointers of how I might fix things.  I blew away my GHC, re-cloned from github, reconfigured and I still get the same error.

The following are the relevant output lines; the problem is that the template-haskell version doesn't seem to match.  I'm not sure whether this is coming from the template-haskell in 8.1 or in 8.0.1 (which I'm using to build 8.1), but checking the latter I have version which I assume should be sufficient.



Configuring ghc-pkg-6.9...
Configuring ghc-8.1...
ghc-cabal: Encountered missing dependencies:
template-haskell ==2.11.* && ==
make[1]: *** [compiler/stage1/<>] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [all] Error 2


internal-229:~/haskell/ghc> cabal update                                                                                                                                     (git)-[master]
Downloading the latest package list from<>
Skipping download: local and remote files match.
internal-229:~/haskell/ghc> cabal install template-haskell                                                                                                                   (git)-[master]
Resolving dependencies...
All the requested packages are already installed:
Use --reinstall if you want to reinstall anyway.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list