Wired-in packages not found

Maarten Faddegon ghc-dev at maartenfaddegon.nl
Thu Mar 27 15:51:40 UTC 2014

Dear Richard,

I tried rebuilding a fresh source distribution which has the same 
problem. I simply don't think template-haskell is included in the source 

I also tried building ghc from the git repository. This time I had (a 
little bit) more success: ghc builds and has template-haskell wired-in. 
However, as I feared, some development in template-haskell's git 
repository is going on that is not compatible with the example I try to 
compile (ClassP is depricated).


On 27/03/14 12:04, Richard Eisenberg wrote:
> Ah -- I understand better now. I'm afraid I've never worked with the source distribution, so I don't have further advice about that. It seems odd, though, that changing rts code would cause problems with wired-in packages. Have you tried just building without any edits and then putting your edits in?
> Richard
> On Mar 27, 2014, at 7:55 AM, Maarten Faddegon <ghc-dev at maartenfaddegon.nl> wrote:
>> Dear Richard, GHC-devs,
>> Thank you for your reply.
>> I am using the 7.6.3 source distribution. According to https://ghc.haskell.org/trac/ghc/wiki/Building/QuickStart "perl boot" is not necessary for source distributions. I did give it a try however (repeating step 3 and 4 afterwards), but it did not solve my problem. There is no sync-all script in the source distribution.
>> I went with a source distribution rather than checking out from the git repository because it was recommended on the "Getting the GHC Sources"-page and because I rather make my changes to an otherwise stable tree. Do you think this is a bad idea?
>> Cheers,
>> Maarten Faddegon
>> On 27/03/14 11:41, Richard Eisenberg wrote:
>>> Did you `./sync-all get`? Did you `perl boot`? You may want to check out the "Building GHC" section of https://ghc.haskell.org/trac/ghc/wiki/Building to make sure you've followed all the steps.
>>> I hope this helps,
>>> Richard
>>> On Mar 27, 2014, at 6:27 AM, Maarten Faddegon <ghc-dev at maartenfaddegon.nl> wrote:
>>>> Dear GHC-devs,
>>>> I want to experiment with the RTS of GHC but the compiler I built has problems finding some wired-in packages. How can I include these?
>>>> This is what I did:
>>>> * Download ghc-7.6.3 sources.
>>>> * Make some changes in rts/
>>>> * ./configure && make
>>>> * inplace/bin/ghc-stage2 --make my_example.lhs -v
>>>> And this is the output produced by the last step:
>>>> ...
>>>> wired-in package ghc-prim mapped to ghc-prim-
>>>> wired-in package integer-gmp mapped to integer-gmp-
>>>> wired-in package base mapped to base-
>>>> wired-in package rts mapped to builtin_rts
>>>> wired-in package template-haskell not found.
>>>> wired-in package dph-seq not found.
>>>> wired-in package dph-par not found.
>>>> ...
>>>> my_example.lhs:88:8:
>>>>     Could not find module `Language.Haskell.TH'
>>>>     Locations searched:
>>>>       Language/Haskell/TH.hs
>>>>       Language/Haskell/TH.lhs
>>>> Thanks,
>>>> Maarten Faddegon
>>>> _______________________________________________
>>>> ghc-devs mailing list
>>>> ghc-devs at haskell.org
>>>> http://www.haskell.org/mailman/listinfo/ghc-devs

More information about the ghc-devs mailing list