Problem with cabal-install 0.6 and data-accessor

Don Stewart dons at
Mon May 31 17:12:28 EDT 2010

> Hi,
> I've found an annoying problem with cabal install 0.6 and
> data-accessor This version of cabal-install fails to parse
> the tested-with property in the cabal file of data-accessor
> This means that *any* package depending on data-accessor (any version)
> will fail to build (at least here it does). The error is:
>   cabal: Couldn't read cabal file "./data-accessor/"
> When unpacking and configuring data-accessor-, I get:
>   cabal-0.6: data-accessor.cabal:67: Parse of field 'tested-with' failed.
> The tested-with field reads:
>   Tested-With:      GHC==6.4.1 && ==6.8.2 && ==6.10.4, JHC==0.7.3
> The versions are: cabal-install version 0.6.2, using version
> of the Cabal library, and GHC 6.10.3. Version 0.8 of cabal-install
> doesn't have this problem.
> I don't think a new version of data-accessor can fix this problem,
> since cabal install will still also try to parse the cabal file for
> the old one. That's why I'm also CC-ing Don: perhaps the offending
> line can somehow be removed on hackage to stop this problem from
> occurring?

I don't think it will try to parse the old one, will it? Only if someone
explicitly asks to look at the old versions?

More information about the cabal-devel mailing list