Cabal bugs/oddities

Duncan Coutts duncan.coutts at
Wed Apr 9 17:28:49 EDT 2008

On Thu, 2008-04-03 at 14:04 +0100, Neil Mitchell wrote:
> Hi,
> All these bugs are against the homeomorphic library I have written. To
> play along, you can do

Thanks Neil, I'll try this when I get a second.

I presume this is on Windows. What version of Cabal were you using?

> darcs get --partial
> Bug 1:
> cabal install worked the first time, running it a second time fails.

Hmm. Nothing obvious from the log and it works for me on Linux. I'll
have to try it on Windows.

> Bug 2: cabal haddock fails

> dist/build/tmp/Data/Homeomorphic/Hash1.hs:4:0:
>      Include/Hash.hs: No such file or directory
> This one may well be my fault, if some extra magic is required for the
> haddock with CPP, but not the building - but that seems weird, if
> there is enough info to build the file, surely there is enough info to
> haddock it

Right, there is no such guarantee at the moment. That's because ghc
--make can find things by import chasing where Cabal needs more stuff
specified explicitly. One day when Cabal does the import chasing they'll
be consistent.

In this case though it doesn't look like on of those problems. It seems
to be because for haddock we're copying files to dist/ and then running
cpp on them. That means of course that relative #includes do not work.
It's not entirely clear to me why we are copying them before running cpp
and not just running cpp on the files from their original locations.

Please file a ticket for this one.

> Bug 3:
> Cabal upload doesn't work:
> $ cabal upload
> Username: ...
> Password: ....

You reported this one before and I fixed it:

$ cabal upload
cabal: the 'upload' command expects one or more .tar.gz packages.

> $ cabal upload dist
> E:\Neil\homeomorphic>cabal upload dist\homeomorphic-0.1.tar.gz
> Hackage username: NeilMitchell
> Hackage password: yoda
> Uploading dist\homeomorphic-0.1.tar.gz...
> ERROR: dist\homeomorphic-0.1.tar.gz: 400 Error in upload
> 400 error in upload - not the worlds most helpful error message...

Indeed. There is an error message available but I'm not sure how we get
at it. Any ideas Ross?

Another ticket for this one.

> Bug 4:
> Cabal upload asks for your password in plain text. That one is
> security related - you are asking for someones password, and giving
> the appearance that you aren't overly fussed about keeping it secret.

I'm happy to add that if anyone can figure out the code to do it. It's
presumably different on ANSI terminals and the Windows command console.

So yet another ticket for that.


More information about the cabal-devel mailing list